Opened 10 years ago

Closed 10 years ago

#72 closed defect (wontfix)

Problem with command history

Reported by: guest Owned by: Jean-Yves Lamoureux
Priority: critical Milestone:
Component: core Version: SVN
Keywords: zsh history up Cc:
Product: neercs

Description

When going back in the history with UP key, cursor returns to the begining of the command line.

Change History (3)

comment:1 Changed 10 years ago by Jean-Yves Lamoureux

Status: newassigned

comment:2 Changed 10 years ago by Jean-Yves Lamoureux

Keywords: zsh history up added

Bug shown in zsh 4.3.6, can't reproduce it using zsh 4.3.10 (either stable or svn). Neercs seems to receive CSI-K with wrong coordinates, so the ANSI emulation seems to do its job properly.

The bug is NOT shown when not sourcing ~/.zshrc or when it is empty, and is present even if ~/.zshrc only exports a single envvar. Again, I can't reproduce it, with or without ~/.zshrc.

comment:3 Changed 10 years ago by Jean-Yves Lamoureux

Resolution: wontfix
Status: assignedclosed

Bug seems to disappear with zsh 4.3.10 on the same machine it failed with 4.3.6.

Note: See TracTickets for help on using tickets.