Opened 11 years ago

Closed 11 years ago

Last modified 10 years ago

#49 closed defect (fixed)

symlink libcucul.la to libcaca.la

Reported by: guest Owned by: Sam Hocevar
Priority: major Milestone:
Component: build system Version: 0.99.beta16
Keywords: Cc:
Product: libcaca

Description

I recently had a problem during a gentoo package installation, about libcucul.la not being found. Effectively that file didn't exist, and symlinking it to libcaca.la solved the problem, as discussed in gentoo forums: http://forums.gentoo.org/viewtopic-t-713934.html

I was checking the changeset [2854] that introduced the symlinks creation:

I don't know exactly what this line does . libcaca.la; \

Probably the symlink should be created there.

Santiago.

Change History (4)

comment:1 Changed 11 years ago by Sam Hocevar

Resolution: fixed
Status: newclosed

Thanks for the report. It’s fixed in [3323], but I also blame Gentoo for relying on .la files for library dependencies.

(note: the line you quote sources libcaca.la so that the shell knows about the environment variable library_names)

comment:2 Changed 11 years ago by guest

Well, apparently it wasn't Gentoo's fault, but mine. Now I tried to compile the problematic package running a tool that fixes broken libraries first and it installed correctly without having to create manually the symlink.

Maybe you could revert this change if you think it can cause more problems or is useless. Thank you and sorry for the inconvenience.

comment:3 Changed 11 years ago by Sam Hocevar

Thanks for the information. I will keep the change for the sake of consistency, just in case. Distributions such as Debian ignore most .la files anyways, and Gentoo will keep working with the symlink.

comment:4 Changed 10 years ago by Sam Hocevar

Component: libcacabuild system
Product: libcaca
Note: See TracTickets for help on using tickets.