source: libcaca/trunk/debian/rules @ 183

Last change on this file since 183 was 19, checked in by Sam Hocevar, 20 years ago
  • real Debian package files.
  • two new types of aliens. only one rules.
  • removed gfx_write in favor of gfx_putchar and gfx_putstr.
  • added bonuses at alien death. they do nothing yet.
  • seeker missiles. 'b' to test.
  • weapon resolution is now 16*char. needs to be generalized.
  • fixed the supernova bugs. center could collide with the tunnel, and the last frame was badly displayed.
  • lots of cleanups everywhere.
  • Property svn:executable set to *
File size: 1.6 KB
Line 
1#!/usr/bin/make -f
2
3#export DH_VERBOSE=1
4export DH_COMPAT=3
5export DEB_HOST_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
6export DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
7
8# FOR AUTOCONF 2.52 AND NEWER ONLY
9ifeq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE))
10  confflags += --build $(DEB_HOST_GNU_TYPE)
11else
12  confflags += --build $(DEB_BUILD_GNU_TYPE) --host $(DEB_HOST_GNU_TYPE)
13endif
14
15confflags += --mandir=\$${prefix}/share/man --infodir=\$${prefix}/share/info
16
17configure: configure-stamp
18configure-stamp:
19        dh_testdir
20        ./configure $(confflags) --prefix=/usr
21        touch configure-stamp
22
23build: configure-stamp build-stamp
24build-stamp:
25        dh_testdir
26        $(MAKE)
27        touch build-stamp
28
29clean:
30        dh_testdir
31        dh_testroot
32        rm -f build-stamp configure-stamp
33        -$(MAKE) distclean
34        dh_clean
35
36install: build
37        dh_testdir
38        dh_testroot
39        dh_clean -k
40        dh_installdirs
41        DESTDIR=`pwd`/debian/ttyvaders/ $(MAKE) install prefix=/usr
42
43# Build architecture-independent files here.
44binary-indep: build install
45# We have nothing to do by default.
46
47# Build architecture-dependent files here.
48binary-arch: build install
49#       dh_testversion
50        dh_testdir
51        dh_testroot
52#       dh_installdebconf       
53        dh_installdocs
54#       dh_installexamples
55        dh_installmenu
56#       dh_installemacsen
57#       dh_installpam
58#       dh_installinit
59        dh_installcron
60        dh_installmanpages
61        dh_installinfo
62#       dh_undocumented
63        dh_installchangelogs
64        dh_link
65        dh_strip
66        dh_compress
67        dh_fixperms
68#       dh_makeshlibs
69        dh_installdeb
70#       dh_perl
71        dh_shlibdeps
72        dh_gencontrol
73        dh_md5sums
74        dh_builddeb
75
76binary: binary-indep binary-arch
77.PHONY: build clean binary-indep binary-arch binary install configure
Note: See TracBrowser for help on using the repository browser.