1 | %define name libcaca |
---|
2 | %define version 0.8 |
---|
3 | %define release 1 |
---|
4 | |
---|
5 | Name: %{name} |
---|
6 | Version: %{version} |
---|
7 | Release: %{release} |
---|
8 | URL: http://sam.zoy.org/projects/libcaca/ |
---|
9 | Source: http://sam.zoy.org/projects/libcaca/%{name}-%{version}.tar.bz2 |
---|
10 | License: GPL |
---|
11 | Group: System/Libraries |
---|
12 | Packager: Sam Hocevar (RPM packages) <sam+rpm@zoy.org> |
---|
13 | BuildRoot: %{_tmppath}/%{name}-buildroot |
---|
14 | Prefix: %{_prefix} |
---|
15 | Buildrequires: XFree86-devel, ncurses-devel >= 5, slang-devel |
---|
16 | Buildrequires: imlib2-devel |
---|
17 | Buildrequires: doxygen, tetex-latex, tetex-dvips |
---|
18 | |
---|
19 | Summary: Text mode graphics library |
---|
20 | %description |
---|
21 | libcaca is the Colour AsCii Art library. It provides high level functions |
---|
22 | for colour text drawing, simple primitives for line, polygon and ellipse |
---|
23 | drawing, as well as powerful image to text conversion routines. |
---|
24 | |
---|
25 | %package -n %{name}-devel |
---|
26 | Summary: Development files for libcaca |
---|
27 | Group: Development/C |
---|
28 | Requires: XFree86-devel, ncurses-devel >= 5, slang-devel |
---|
29 | Provides: %{name}-devel = %{version}-%{release} |
---|
30 | %description -n %{name}-devel |
---|
31 | libcaca is the Colour AsCii Art library. It provides high level functions |
---|
32 | for colour text drawing, simple primitives for line, polygon and ellipse |
---|
33 | drawing, as well as powerful image to text conversion routines. |
---|
34 | |
---|
35 | This package contains the header files and static libraries needed to |
---|
36 | compile applications or shared objects that use libcaca. |
---|
37 | |
---|
38 | %package -n caca-utils |
---|
39 | Summary: Text mode graphics utilities |
---|
40 | Group: Graphics |
---|
41 | %description -n caca-utils |
---|
42 | This package contains utilities and demonstration programs for libcaca, the |
---|
43 | Colour AsCii Art library. |
---|
44 | |
---|
45 | cacaview is a simple image viewer for the terminal. It opens most image |
---|
46 | formats such as JPEG, PNG, GIF etc. and renders them on the terminal using |
---|
47 | ASCII art. The user can zoom and scroll the image, set the dithering method |
---|
48 | or enable anti-aliasing. |
---|
49 | |
---|
50 | cacaball is a tiny graphic program that renders animated ASCII metaballs on |
---|
51 | the screen, cacafire is a port of AALib's aafire and displays burning ASCII |
---|
52 | art flames, cacamoir animates colourful moire circles and cacaplas displays |
---|
53 | an old school plasma effect. |
---|
54 | |
---|
55 | cacademo is a simple application that shows the libcaca rendering features |
---|
56 | such as line and ellipses drawing, triangle filling and sprite blitting. |
---|
57 | |
---|
58 | %prep |
---|
59 | case "${RPM_COMMAND:-all}" in |
---|
60 | all) |
---|
61 | %setup -q |
---|
62 | ;;esac |
---|
63 | |
---|
64 | %build |
---|
65 | case "${RPM_COMMAND:-all}" in |
---|
66 | all) |
---|
67 | ./configure --prefix=%{_prefix} \ |
---|
68 | --libdir=%{_libdir} \ |
---|
69 | --bindir=\${prefix}/bin \ |
---|
70 | --mandir=\${prefix}/share/man \ |
---|
71 | --infodir=\${prefix}/share/info \ |
---|
72 | --enable-slang --enable-ncurses --enable-x11 --enable-imlib2 --enable-doc |
---|
73 | ;;esac |
---|
74 | make |
---|
75 | |
---|
76 | %install |
---|
77 | rm -rf %{buildroot} |
---|
78 | %makeinstall |
---|
79 | mv %{buildroot}/%{_prefix}/share/doc/libcaca-dev %{buildroot}/%{_prefix}/share/doc/libcaca-devel-%{version} |
---|
80 | mkdir %{buildroot}/%{_prefix}/share/doc/caca-utils-%{version} |
---|
81 | cp `find %{buildroot}/%{_prefix}/share/doc/libcaca-devel-%{version}/ -name '[A-Z]*'` %{buildroot}/%{_prefix}/share/doc/caca-utils-%{version}/ |
---|
82 | |
---|
83 | %clean |
---|
84 | rm -rf %{buildroot} |
---|
85 | |
---|
86 | %files -n %{name}-devel |
---|
87 | %defattr(-,root,root) |
---|
88 | %{_libdir}/* |
---|
89 | %{_prefix}/bin/caca-config |
---|
90 | %{_prefix}/include/* |
---|
91 | %{_prefix}/share/doc/libcaca-devel-%{version}/* |
---|
92 | %{_prefix}/share/man/man1/caca-config.1* |
---|
93 | %{_prefix}/share/man/man3/* |
---|
94 | |
---|
95 | %files -n caca-utils |
---|
96 | %defattr(-,root,root) |
---|
97 | %{_prefix}/bin/cacaball |
---|
98 | %{_prefix}/bin/cacademo |
---|
99 | %{_prefix}/bin/cacafire |
---|
100 | %{_prefix}/bin/cacamoir |
---|
101 | %{_prefix}/bin/cacaplas |
---|
102 | %{_prefix}/bin/cacaview |
---|
103 | %{_prefix}/share/doc/caca-utils-%{version}/* |
---|
104 | %{_prefix}/share/libcaca/* |
---|
105 | %{_prefix}/share/man/man1/cacaball.1* |
---|
106 | %{_prefix}/share/man/man1/cacademo.1* |
---|
107 | %{_prefix}/share/man/man1/cacafire.1* |
---|
108 | %{_prefix}/share/man/man1/cacamoir.1* |
---|
109 | %{_prefix}/share/man/man1/cacaplas.1* |
---|
110 | %{_prefix}/share/man/man1/cacaview.1* |
---|
111 | |
---|
112 | %changelog |
---|
113 | * Sun Jan 18 2004 Sam Hocevar (RPM packages) <sam+rpm@zoy.org> 0.8-1 |
---|
114 | - new release |
---|
115 | |
---|
116 | * Sat Jan 7 2004 Sam Hocevar (RPM packages) <sam+rpm@zoy.org> 0.7-1 |
---|
117 | - new release |
---|
118 | |
---|
119 | * Sat Jan 4 2004 Sam Hocevar (RPM packages) <sam+rpm@zoy.org> 0.6-2 |
---|
120 | - install documentation into {doc}/package-version instead of {doc}/package |
---|
121 | - added tetex-dvips to the build dependencies |
---|
122 | |
---|
123 | * Sat Jan 3 2004 Sam Hocevar (RPM packages) <sam+rpm@zoy.org> 0.6-1 |
---|
124 | - new release |
---|
125 | - more detailed descriptions |
---|
126 | - split the RPM into libcaca-devel and caca-utils |
---|
127 | - packages are rpmlint clean |
---|
128 | |
---|
129 | * Mon Dec 29 2003 Richard Zidlicky <rz@linux-m68k.org> 0.5-1 |
---|
130 | - created specfile |
---|
131 | |
---|