1 | %define name libcaca |
---|
2 | %define version 0.6 |
---|
3 | %define release 1 |
---|
4 | |
---|
5 | Name: %{name} |
---|
6 | Version: %{version} |
---|
7 | Release: %{release} |
---|
8 | URL: http://sam.zoy.org/projects/libcaca/ |
---|
9 | Source: http://sam.zoy.org/projects/libcaca/%{name}-%{version}.tar.bz2 |
---|
10 | License: GPL |
---|
11 | Group: System/Libraries |
---|
12 | Packager: Sam Hocevar (RPM packages) <sam+rpm@zoy.org> |
---|
13 | BuildRoot: %{_tmppath}/%{name}-buildroot |
---|
14 | Prefix: %{_prefix} |
---|
15 | Buildrequires: XFree86-devel, ncurses-devel >= 5, slang-devel |
---|
16 | Buildrequires: imlib2-devel |
---|
17 | Buildrequires: doxygen, tetex-latex |
---|
18 | |
---|
19 | Summary: Text mode graphics library |
---|
20 | %description |
---|
21 | libcaca is the Colour AsCii Art library. It provides high level functions |
---|
22 | for colour text drawing, simple primitives for line, polygon and ellipse |
---|
23 | drawing, as well as powerful image to text conversion routines. |
---|
24 | |
---|
25 | %package -n %{name}-devel |
---|
26 | Summary: Development files for libcaca |
---|
27 | Group: Development/C |
---|
28 | Requires: XFree86-devel, ncurses-devel >= 5, slang-devel |
---|
29 | Provides: %{name}-devel = %{version}-%{release} |
---|
30 | %description -n %{name}-devel |
---|
31 | libcaca is the Colour AsCii Art library. It provides high level functions |
---|
32 | for colour text drawing, simple primitives for line, polygon and ellipse |
---|
33 | drawing, as well as powerful image to text conversion routines. |
---|
34 | |
---|
35 | This package contains the header files and static libraries needed to |
---|
36 | compile applications or shared objects that use libcaca. |
---|
37 | |
---|
38 | %package -n caca-utils |
---|
39 | Summary: Text mode graphics utilities |
---|
40 | Group: Graphics |
---|
41 | %description -n caca-utils |
---|
42 | This package contains utilities and demonstration programs for libcaca, the |
---|
43 | Colour AsCii Art library. |
---|
44 | |
---|
45 | cacaview is a simple image viewer for the terminal. It opens most image |
---|
46 | formats such as JPEG, PNG, GIF etc. and renders them on the terminal using |
---|
47 | ASCII art. The user can zoom and scroll the image, set the dithering method |
---|
48 | or enable anti-aliasing. |
---|
49 | |
---|
50 | cacafire is a port of AALib's aafire and displays burning ASCII art flames. |
---|
51 | |
---|
52 | cacademo is a simple application that shows the libcaca rendering features |
---|
53 | such as line and ellipses drawing, triangle filling, and sprite blitting. |
---|
54 | |
---|
55 | caca-spritedit is a simple sprite viewer for libcaca. |
---|
56 | |
---|
57 | %prep |
---|
58 | case "${RPM_COMMAND:-all}" in |
---|
59 | all) |
---|
60 | %setup -q |
---|
61 | ;;esac |
---|
62 | |
---|
63 | %build |
---|
64 | case "${RPM_COMMAND:-all}" in |
---|
65 | all) |
---|
66 | ./configure --prefix=%{_prefix} \ |
---|
67 | --libdir=%{_libdir} \ |
---|
68 | --bindir=\${prefix}/bin \ |
---|
69 | --mandir=\${prefix}/share/man \ |
---|
70 | --infodir=\${prefix}/share/info \ |
---|
71 | --enable-slang --enable-ncurses --enable-x11 --enable-imlib2 |
---|
72 | ;;esac |
---|
73 | make |
---|
74 | |
---|
75 | %install |
---|
76 | rm -rf %{buildroot} |
---|
77 | %makeinstall |
---|
78 | mv %{buildroot}/%{_prefix}/share/doc/libcaca-dev %{buildroot}/%{_prefix}/share/doc/libcaca-devel |
---|
79 | mkdir %{buildroot}/%{_prefix}/share/doc/caca-utils |
---|
80 | cp `find %{buildroot}/%{_prefix}/share/doc/libcaca-devel/ -name '[A-Z]*'` %{buildroot}/%{_prefix}/share/doc/caca-utils/ |
---|
81 | |
---|
82 | %clean |
---|
83 | rm -rf %{buildroot} |
---|
84 | |
---|
85 | %files -n %{name}-devel |
---|
86 | %defattr(-,root,root) |
---|
87 | %{_libdir}/* |
---|
88 | %{_prefix}/bin/caca-config |
---|
89 | %{_prefix}/include/* |
---|
90 | %{_prefix}/share/doc/libcaca-devel/* |
---|
91 | %{_prefix}/share/man/man1/caca-config.1* |
---|
92 | %{_prefix}/share/man/man3/* |
---|
93 | |
---|
94 | %files -n caca-utils |
---|
95 | %defattr(-,root,root) |
---|
96 | %{_prefix}/bin/cacademo |
---|
97 | %{_prefix}/bin/cacafire |
---|
98 | %{_prefix}/bin/cacaview |
---|
99 | %{_prefix}/bin/caca-spritedit |
---|
100 | %{_prefix}/share/doc/caca-utils/* |
---|
101 | %{_prefix}/share/libcaca/* |
---|
102 | %{_prefix}/share/man/man1/cacademo.1* |
---|
103 | %{_prefix}/share/man/man1/cacafire.1* |
---|
104 | %{_prefix}/share/man/man1/cacaview.1* |
---|
105 | %{_prefix}/share/man/man1/caca-spritedit.1* |
---|
106 | |
---|
107 | %changelog |
---|
108 | * Sat Jan 3 2004 Sam Hocevar (RPM packages) <sam+rpm@zoy.org> 0.6-1 |
---|
109 | - new release |
---|
110 | |
---|
111 | * Mon Dec 29 2003 Richard Zidlicky <rz@linux-m68k.org> 0.5-1 |
---|
112 | - created specfile |
---|
113 | |
---|