Changeset 4025 for neercs


Ignore:
Timestamp:
Nov 23, 2009, 2:16:05 PM (10 years ago)
Author:
Jean-Yves Lamoureux
Message:
  • Added Python 3.1 support in configure.ac
File:
1 edited

Legend:

Unmodified
Added
Removed
  • neercs/trunk/configure.ac

    r3996 r4025  
    4949fi
    5050
     51
    5152dnl conditional builds
    5253AC_ARG_ENABLE(debug,
    5354  [  --enable-debug          build debug versions of neercs (default no)])
     55AC_ARG_ENABLE(python,
     56  [  --enable-python         build Python interpreter (default yes)])
     57AS_IF([test "x$enable_python" != "xno"], [
     58  enable_python="yes"
     59])
    5460
    5561CACA="no"
     
    95101AC_DEFINE(_GNU_SOURCE, 1, [Use GNU extentions])
    96102
     103PYTHON3="yes"
     104if test "${enable_python}" != "no"; then
     105PKG_CHECK_MODULES(PYTHON3, python3 >= 3.1,
     106 [PYTHON3="yes"  AC_DEFINE(USE_PYTHON, 1, [Define to 1 to use Python interpreter])],
     107 [AC_MSG_RESULT(you need Python 3.1 or later to compile the interpreter)
     108])
     109fi
     110
    97111
    98112# Optimizations
Note: See TracChangeset for help on using the changeset viewer.