Ignore:
Timestamp:
Oct 23, 2008, 2:30:18 PM (12 years ago)
Author:
Sam Hocevar
Message:

libpipi: the GDI+ codec can now compile using mingw32, unfortunately it
does not link yet due to a bug in mingw's ld.

File:
1 edited

Legend:

Unmodified
Added
Removed
  • libpipi/trunk/configure.ac

    r3071 r3074  
    2121AM_PROG_CC_C_O
    2222AC_PROG_CPP
     23AC_PROG_CXX
     24AC_PROG_CXXCPP
    2325AC_PROG_OBJC
    2426_AM_DEPENDENCIES([OBJC])
     
    149151fi
    150152AM_CONDITIONAL(USE_GDI, test "${ac_cv_my_have_gdi}" = "yes")
    151 AM_CONDITIONAL(USE_GDIPLUS, test "${ac_cv_my_have_gdi}" = "yes")
     153
     154# Use Windows GDI+?
     155ac_cv_my_have_gdiplus="no"
     156AC_LANG_PUSH(C++)
     157AC_CHECK_HEADERS(Gdiplus.h,
     158 [ac_cv_my_have_gdiplus="yes"],
     159 [ac_cv_my_have_gdiplus="no"],
     160 [#include <windows.h>])
     161AC_LANG_POP(C++)
     162if test "${ac_cv_my_have_gdiplus}" != "no"; then
     163  AC_DEFINE(USE_GDIPLUS, 1, Define to 1 to use GDI+)
     164fi
     165AM_CONDITIONAL(USE_GDIPLUS, test "${ac_cv_my_have_gdiplus}" = "yes")
    152166
    153167# Use Cocoa?
Note: See TracChangeset for help on using the changeset viewer.