Ignore:
Timestamp:
Sep 9, 2006, 5:38:06 PM (14 years ago)
Author:
Sam Hocevar
Message:
  • Added an emulation layer for pre-1.0 libcaca API. Legacy applications just need to include <caca0.h> instead of <caca.h> and should be source- compatible with old versions of libcaca.

Most of the old API works, except features and caca_sqrt(). Sprites do
work API-wise but due to the new format they are no longer working in
the same way.

Location:
libcaca/trunk/caca
Files:
2 added
1 edited

Legend:

Unmodified
Added
Removed
  • libcaca/trunk/caca/Makefile.am

    r977 r1013  
    77pkgconfigdir = $(libdir)/pkgconfig
    88
    9 include_HEADERS = caca.h
     9include_HEADERS = caca.h caca0.h
    1010
    1111lib_LTLIBRARIES = libcaca.la
     
    1515        caca.h \
    1616        caca_internals.h \
     17        caca0.c \
     18        caca0.h \
    1719        graphics.c \
    1820        event.c \
Note: See TracChangeset for help on using the changeset viewer.