source: ttyvaders/trunk/bootstrap @ 28

Last change on this file since 28 was 18, checked in by Sam Hocevar, 18 years ago
  • autotoolificationized the whole thing.
  • Property svn:executable set to *
File size: 920 bytes
RevLine 
[18]1#! /bin/sh
2set -x
3
4rm -f aclocal.m4 configure config.guess config.log config.sub ltmain.sh libtool ltconfig missing mkinstalldirs depcomp install-sh
5
6# Check for automake
7amvers="none"
8if automake-1.7 --version >/dev/null 2>&1
9then
10  amvers="-1.7"
11else
12  if automake-1.6 --version >/dev/null 2>&1
13  then
14    amvers="-1.6"
15  else
16    if automake-1.5 --version >/dev/null 2>&1
17    then
18      amvers="-1.5"
19    else
20      if automake --version > /dev/null 2>&1
21      then
22        amvers=`automake --version | sed -e '1s/[^0-9]*//' -e q`
23 
24        if expr "$amvers" "<" "1.5" > /dev/null 2>&1
25        then amvers="none"
26        else amvers=""
27        fi       
28      fi
29    fi
30  fi
31fi
32
33if test x$amvers = xnone
34then
35  set +x
36  echo "you need automake version 1.5 or later"
37  exit 1
38fi
39
40aclocal${amvers} || exit 1
41autoheader || exit 1
42automake${amvers} --add-missing --copy || exit 1
43autoconf || exit 1
44rm -f config.cache
Note: See TracBrowser for help on using the repository browser.