source: libcaca/trunk/caca-php/config.m4 @ 3154

Last change on this file since 3154 was 3154, checked in by nico, 12 years ago
  • Modify error message in sample program dithering.php
File size: 522 bytes
Line 
1PHP_ARG_ENABLE(caca, whether to enable Libcaca support,
2[ --enable-caca   Enable Libcaca support])
3
4if test "$PHP_CACA" = "yes"; then
5        AC_CHECK_LIB(caca, caca_get_version, [
6                PHP_ADD_LIBRARY(caca,, CACA_SHARED_LIBADD)
7        ], [
8                AC_MSG_ERROR(libcaca development files required !)
9        ])
10
11        AC_CHECK_LIB(gd, gdImageSetPixel, [
12                PHP_ADD_LIBRARY(gd,, CACA_SHARED_LIBADD)
13                AC_DEFINE(HAVE_GD, 1, [Wheter you have development files of gd])
14        ])
15
16        PHP_NEW_EXTENSION(caca, php_caca.c, $ext_shared,,)
17        PHP_SUBST(CACA_SHARED_LIBADD)
18fi
Note: See TracBrowser for help on using the repository browser.